// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\$\\\w*{[^}]+}(*SKIP)(*F)|{[^}]*}").unwrap();
let string = "Lorem Ipsum $\\mathbb{R}$ dolore. {Author} $\\{1,\\dotsc,n}$
$\\mathbb{R} $ dolore. {Author}";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}