const regex = /\$\\\w*{[^}]+}(*SKIP)(*F)|{[^}]*}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\\\\\w*{[^}]+}(*SKIP)(*F)|{[^}]*}', 'gm')
const str = `Lorem Ipsum \$\\mathbb{R}\$ dolore. {Author} \$\\{1,\\dotsc,n}\$
\$\\mathbb{R} \$ dolore. {Author}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);