use strict;
my $str = 'Lorem Ipsum $\\mathbb{R}$ dolore. {Author} $\\{1,\\dotsc,n}$
$\\mathbb{R} $ dolore. {Author}';
my $regex = qr/\$\\\w*{[^}]+}(*SKIP)(*F)|{[^}]*}/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";