#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<\/[^>]+>)[^<]*(<[^>]+>)"
Local $sString = "<h1>This is the title</h1>This is a bit of text with no HTML around it<p>This is within a paragraph tag</p>"
Local $sSubst = "(<\/[^>]+>)[^<]*(<[^>]+>)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)