using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\/[^>]+>)[^<]*(<[^>]+>)";
string substitution = @"(<\/[^>]+>)[^<]*(<[^>]+>)";
string input = @"<h1>This is the title</h1>This is a bit of text with no HTML around it<p>This is within a paragraph tag</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}