package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<\/[^>]+>)[^<]*(<[^>]+>)`)
var str = `<h1>This is the title</h1>This is a bit of text with no HTML around it<p>This is within a paragraph tag</p>`
var substitution = "(<\/[^>]+>)[^<]*(<[^>]+>)"
fmt.Println(re.ReplaceAllString(str, substitution))
}