import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\/[^>]+>)[^<]*(<[^>]+>)";
final String string = "<h1>This is the title</h1>This is a bit of text with no HTML around it<p>This is within a paragraph tag</p>";
final String subst = "(<\\/[^>]+>)[^<]*(<[^>]+>)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}