# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<\/[^>]+>)[^<]*(<[^>]+>)"
test_str = "<h1>This is the title</h1>This is a bit of text with no HTML around it<p>This is within a paragraph tag</p>"
subst = "(<\\/[^>]+>)[^<]*(<[^>]+>)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.