// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<\/[^>]+>)[^<]*(<[^>]+>)").unwrap();
let string = "<h1>This is the title</h1>This is a bit of text with no HTML around it<p>This is within a paragraph tag</p>";
let substitution = "(<\\/[^>]+>)[^<]*(<[^>]+>)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}