#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b-\b"
Local $sString = "-fjdkls six-nation-golden-cup-award - jfkdl-"
Local $sSubst = "\\-/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)