import Foundation
let pattern = #"\b-\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"-fjdkls six-nation-golden-cup-award - jfkdl-"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\-/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)