import re
regex = re.compile(r"\b-\b")
test_str = "-fjdkls six-nation-golden-cup-award - jfkdl-"
subst = "\\\\-/"
result = regex.sub(subst, test_str)
if result:
print(result)