const regex = /\b-\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b-\\b', 'g')
const str = `-fjdkls six-nation-golden-cup-award - jfkdl-`;
const subst = `\\-/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);