using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b-\b";
string substitution = @"\\-/";
string input = @"-fjdkls six-nation-golden-cup-award - jfkdl-";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}