#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Z]{2}).*?(\d{2}).*?([A-Z]{2}).*?(\d{4})"
Local $sString = "sdnak hsd fds fnsdf APsdf09sdf BN fddsdalf 7886sd f" & @CRLF & _
"7:1AP09BN7886"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")