import Foundation
let pattern = #"([A-Z]{2}).*?(\d{2}).*?([A-Z]{2}).*?(\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
sdnak hsd fds fnsdf APsdf09sdf BN fddsdalf 7886sd f
7:1AP09BN7886
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)