import re
regex = re.compile(r"([A-Z]{2}).*?(\d{2}).*?([A-Z]{2}).*?(\d{4})")
test_str = ("sdnak hsd fds fnsdf APsdf09sdf BN fddsdalf 7886sd f\n"
"7:1AP09BN7886")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")