import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{2}).*?(\\d{2}).*?([A-Z]{2}).*?(\\d{4})";
final String string = "sdnak hsd fds fnsdf APsdf09sdf BN fddsdalf 7886sd f\n"
+ "7:1AP09BN7886";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}