re = /([A-Z]{2}).*?(\d{2}).*?([A-Z]{2}).*?(\d{4})/
str = 'sdnak hsd fds fnsdf APsdf09sdf BN fddsdalf 7886sd f
7:1AP09BN7886'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end