package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z]{2}).*?(\d{2}).*?([A-Z]{2}).*?(\d{4})`)
var str = `sdnak hsd fds fnsdf APsdf09sdf BN fddsdalf 7886sd f
7:1AP09BN7886`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}