$re = '/([A-Z]{2}).*?(\d{2}).*?([A-Z]{2}).*?(\d{4})/';
$str = 'sdnak hsd fds fnsdf APsdf09sdf BN fddsdalf 7886sd f
7:1AP09BN7886';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);