const regex = /([A-Z]{2}).*?(\d{2}).*?([A-Z]{2}).*?(\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]{2}).*?(\\d{2}).*?([A-Z]{2}).*?(\\d{4})', 'g')
const str = `sdnak hsd fds fnsdf APsdf09sdf BN fddsdalf 7886sd f
7:1AP09BN7886`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}