# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\bstyle="|(?!^)\G)([^;"]+;?)\s*(?:"$)?/$1\n/gm;t' <<< "style=\"bla: bla; bla:bla\""