$re = '/(?:\bstyle="|(?!^)\G)([^;"]+;?)\s*(?:"$)?/m';
$str = 'style="bla: bla; bla:bla"';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;