re = /(?:\bstyle="|(?!^)\G)([^;"]+;?)\s*(?:"$)?/m
str = 'style="bla: bla; bla:bla"'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result