import Foundation
let pattern = #"(?:\bstyle="|(?!^)\G)([^;"]+;?)\s*(?:"$)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"style="bla: bla; bla:bla""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)