const regex = /(?:\bstyle="|(?!^)\G)([^;"]+;?)\s*(?:"$)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\bstyle="|(?!^)\\G)([^;"]+;?)\\s*(?:"$)?', 'gm')
const str = `style="bla: bla; bla:bla"`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);