use strict;
my $str = 'style="bla: bla; bla:bla"';
my $regex = qr/(?:\bstyle="|(?!^)\G)([^;"]+;?)\s*(?:"$)?/mp;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";