using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\bstyle=""|(?!^)\G)([^;""]+;?)\s*(?:""$)?";
string substitution = @"$1\n";
string input = @"style=""bla: bla; bla:bla""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}