#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*>"
Local $sString = "<span data-toggle="tooltip" title="xxx">FUU</span><br><span class="btn btn-outline-secondary font-sm p-1" onclick="bar(event)"><i class="fa fa-bar-chart" aria-hidden="true"></i></span><span data-toggle="tooltip" data-html="true" title="fuu (<b>BAR</b>) is based on fuu.">FUU</span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")