const regex = /<(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?:[^>=]|=\'[^\']*\'|="[^"]*"|=[^\'"][^\\s>]*)*>', 'gi')
const str = `<span data-toggle="tooltip" title="xxx">FUU</span><br><span class="btn btn-outline-secondary font-sm p-1" onclick="bar(event)"><i class="fa fa-bar-chart" aria-hidden="true"></i></span><span data-toggle="tooltip" data-html="true" title="fuu (<b>BAR</b>) is based on fuu.">FUU</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}