import re
regex = re.compile(r"<(?:[^>=]|='[^']*'|=\"[^\"]*\"|=[^'\"][^\s>]*)*>", flags=re.IGNORECASE)
test_str = "<span data-toggle=\"tooltip\" title=\"xxx\">FUU</span><br><span class=\"btn btn-outline-secondary font-sm p-1\" onclick=\"bar(event)\"><i class=\"fa fa-bar-chart\" aria-hidden=\"true\"></i></span><span data-toggle=\"tooltip\" data-html=\"true\" title=\"fuu (<b>BAR</b>) is based on fuu.\">FUU</span>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")