using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?:[^>=]|='[^']*'|=""[^""]*""|=[^'""][^\s>]*)*>";
string input = @"<span data-toggle=""tooltip"" title=""xxx"">FUU</span><br><span class=""btn btn-outline-secondary font-sm p-1"" onclick=""bar(event)""><i class=""fa fa-bar-chart"" aria-hidden=""true""></i></span><span data-toggle=""tooltip"" data-html=""true"" title=""fuu (<b>BAR</b>) is based on fuu."">FUU</span>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}