// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*>"#).unwrap();
let string = "<span data-toggle=\"tooltip\" title=\"xxx\">FUU</span><br><span class=\"btn btn-outline-secondary font-sm p-1\" onclick=\"bar(event)\"><i class=\"fa fa-bar-chart\" aria-hidden=\"true\"></i></span><span data-toggle=\"tooltip\" data-html=\"true\" title=\"fuu (<b>BAR</b>) is based on fuu.\">FUU</span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}