re = /<(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*>/i
str = '<span data-toggle="tooltip" title="xxx">FUU</span><br><span class="btn btn-outline-secondary font-sm p-1" onclick="bar(event)"><i class="fa fa-bar-chart" aria-hidden="true"></i></span><span data-toggle="tooltip" data-html="true" title="fuu (<b>BAR</b>) is based on fuu.">FUU</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end