use strict;
my $str = '<span data-toggle="tooltip" title="xxx">FUU</span><br><span class="btn btn-outline-secondary font-sm p-1" onclick="bar(event)"><i class="fa fa-bar-chart" aria-hidden="true"></i></span><span data-toggle="tooltip" data-html="true" title="fuu (<b>BAR</b>) is based on fuu.">FUU</span>';
my $regex = qr/<(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}