import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:[^>=]|='[^']*'|=\"[^\"]*\"|=[^'\"][^\\s>]*)*>";
final String string = "<span data-toggle=\"tooltip\" title=\"xxx\">FUU</span><br><span class=\"btn btn-outline-secondary font-sm p-1\" onclick=\"bar(event)\"><i class=\"fa fa-bar-chart\" aria-hidden=\"true\"></i></span><span data-toggle=\"tooltip\" data-html=\"true\" title=\"fuu (<b>BAR</b>) is based on fuu.\">FUU</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}