# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?\.pdf).*/$1/gm;t' <<< "['A_LOT_OF_TEXT'].pdf&blobcol=urldata&pdftable=MungoBlobs"