import Foundation
let pattern = #"^(.*?\.pdf).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"['A_LOT_OF_TEXT'].pdf&blobcol=urldata&pdftable=MungoBlobs"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)