#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*?\.pdf).*"
Local $sString = "['A_LOT_OF_TEXT'].pdf&blobcol=urldata&pdftable=MungoBlobs"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)