package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?\.pdf).*`)
var str = `['A_LOT_OF_TEXT'].pdf&blobcol=urldata&pdftable=MungoBlobs`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}