$re = '/^(.*?\.pdf).*/m';
$str = '[\'A_LOT_OF_TEXT\'].pdf&blobcol=urldata&pdftable=MungoBlobs';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;