use strict;
my $str = '[\'A_LOT_OF_TEXT\'].pdf&blobcol=urldata&pdftable=MungoBlobs';
my $regex = qr/^(.*?\.pdf).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";