using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?\.pdf).*";
string substitution = @"$1";
string input = @"['A_LOT_OF_TEXT'].pdf&blobcol=urldata&pdftable=MungoBlobs";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}