const regex = /^(.*?\.pdf).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?\\.pdf).*', 'gm')
const str = `['A_LOT_OF_TEXT'].pdf&blobcol=urldata&pdftable=MungoBlobs`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);