#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?((0(\.[0-9]+)?)|([1-9]+[0-9]*(\.[0-9]+)?))$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
"0.1" & @CRLF & _
"1.12" & @CRLF & _
"12.0123" & @CRLF & _
"1.23" & @CRLF & _
"-1" & @CRLF & _
"-12" & @CRLF & _
"-0.1" & @CRLF & _
"-1.12" & @CRLF & _
"-12.0123" & @CRLF & _
"-01.23" & @CRLF & _
"01.23" & @CRLF & _
"3000001230120312030123011.2323" & @CRLF & _
"12." & @CRLF & _
"" & @CRLF & _
"--123" & @CRLF & _
"-2323-" & @CRLF & _
"23.23.23" & @CRLF & _
"34..34"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")