import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?((0(\\.[0-9]+)?)|([1-9]+[0-9]*(\\.[0-9]+)?))$";
final String string = "0\n"
+ "1\n"
+ "12\n"
+ "123\n"
+ "0.1\n"
+ "1.12\n"
+ "12.0123\n"
+ "1.23\n"
+ "-1\n"
+ "-12\n"
+ "-0.1\n"
+ "-1.12\n"
+ "-12.0123\n"
+ "-01.23\n"
+ "01.23\n"
+ "3000001230120312030123011.2323\n"
+ "12.\n\n"
+ "--123\n"
+ "-2323-\n"
+ "23.23.23\n"
+ "34..34";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}