import re
regex = re.compile(r"^-?((0(\.[0-9]+)?)|([1-9]+[0-9]*(\.[0-9]+)?))$", flags=re.MULTILINE)
test_str = ("0\n"
"1\n"
"12\n"
"123\n"
"0.1\n"
"1.12\n"
"12.0123\n"
"1.23\n"
"-1\n"
"-12\n"
"-0.1\n"
"-1.12\n"
"-12.0123\n"
"-01.23\n"
"01.23\n"
"3000001230120312030123011.2323\n"
"12.\n\n"
"--123\n"
"-2323-\n"
"23.23.23\n"
"34..34")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")