use strict;
my $str = '0
1
12
123
0.1
1.12
12.0123
1.23
-1
-12
-0.1
-1.12
-12.0123
-01.23
01.23
3000001230120312030123011.2323
12.
--123
-2323-
23.23.23
34..34';
my $regex = qr/^-?((0(\.[0-9]+)?)|([1-9]+[0-9]*(\.[0-9]+)?))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}