const regex = /^-?((0(\.[0-9]+)?)|([1-9]+[0-9]*(\.[0-9]+)?))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?((0(\\.[0-9]+)?)|([1-9]+[0-9]*(\\.[0-9]+)?))$', 'gm')
const str = `0
1
12
123
0.1
1.12
12.0123
1.23
-1
-12
-0.1
-1.12
-12.0123
-01.23
01.23
3000001230120312030123011.2323
12.
--123
-2323-
23.23.23
34..34`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}